Request for shutting down export script to old swgcraft.com

Discussion and suggestions regarding the site and/or forum.

Moderator: Forum Moderator

ordio
Novice Crafter
Posts: 20
Joined: Mon Mar 26, 2007 5:04 pm
Location: Valcyn

Post by ordio » Tue Sep 25, 2007 5:49 pm

Sobuno wrote:
ordio wrote:
Sobuno wrote:When the synchronization is down, you should mark resources as unavailable on SWGCraft.com instead of here. We use their export script in a way to search for resources made unavailable recently, so if you mark it unavailable over there, it should automatically despawn here too
Yeah i was hoping to not have to do that (with the single unavailable click over there, its very time consuming)... I like the unavailable feature here...

Anyway, thank you...
Yeah, it is unfortunate, but I can't seem to track down the issues people are having.... And seeing that we don't want to mess up SWGCraft.com's database, we have to be carefull
As a programmer, i completely understand...

I personally didn't notice any issues with setting "unavailables" here, and having them sent to swgcraft.com. When i set them here, they were sent over with no problem... at least, before synchronization was turned off.

Perhaps one thing you may want to let users know here, that synchronization between swgcraft.com and swgcraft.co.uk is currently a one way (swgcraft.com -> swgcraft.co.uk) until some bugs can be figured out... Maybe on the "new entry" screen, making unavailable screen...
Its just a thought...
:)
i didn't know that the synchronization was shut off until i came here...

Thanks again!

Milla
Apprentice Crafter
Posts: 77
Joined: Thu Jul 12, 2007 4:01 pm

Post by Milla » Tue Oct 16, 2007 6:17 am

Hello,

I wonder if you have re-enabled the synchronization towards the old site. Today I have found 2-day old entries made by the export script on my server pages, plus the usual signs of destructive entry removal/deletion.

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Post by Sobuno » Tue Oct 16, 2007 9:35 pm

Milla wrote:Hello,

I wonder if you have re-enabled the synchronization towards the old site. Today I have found 2-day old entries made by the export script on my server pages, plus the usual signs of destructive entry removal/deletion.
I deliberately left the mail parser synchronization on back when I turned the rest off to see what was causing the issue... It is odd that nobody has noticed anything untill now


And I still don't get how we can make resources mysteriously disappear, every change should be listed on the Recent Changes page on Trokk's site, right? All we do is emulate a browser so it is really odd

Anyway, could you mention some of the resources that got messed up?

Milla
Apprentice Crafter
Posts: 77
Joined: Thu Jul 12, 2007 4:01 pm

Post by Milla » Tue Oct 16, 2007 10:52 pm

I can't tell you for sure which of the resources were messed up, honestly I was too pissed to mark the compromised entries.

But there is something strange going on between the old site and the new one.

I noticed that many entries that I made myself now show a certain La'Ato as the user who entered the resource.

The only time I saw such thing happen was when the export script of this site removed/deleted entries on the old site in such a way that not only the resource was removed, but all of its stats were also deleted. When I re-entered that resource with all its stats, the old site treated it as if it had been a resource entered by somebody else WITHOUT stats, and I got a "resource has been successfully changed" message, and the deleted entry reappeared, now correctly with all of its stats, and with my name as the user who submitted it.

I guess probably the user called La'Ato tried to reenter the missing entries, and the same thing happened to him.

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Post by Zimoon » Wed Oct 17, 2007 6:37 am

Milla, next time you notice such an error, or any anomaly, please take notes. I am pretty confident that Sobuno et al can trace them in their logs. But without notes, what should they trace?

I believe S posted the idea behind the synch somewhere. I will try to track that post down today and see if my magic eyes can find something in the thought process behind them. Unless S is kind enough to PM me the scrips? 8)

/Z

Milla
Apprentice Crafter
Posts: 77
Joined: Thu Jul 12, 2007 4:01 pm

Post by Milla » Wed Oct 17, 2007 6:51 am

Now I noticed something:

On Farstar / Tatooine there is an entry made by Isskozz:
Isiawaiide, Hardened Arveshium Steel (Entered By Isskozz / Not Verified) (Unavailable)
No stats available for this resource (Edit Stats)
Yesterday, I updated swgcraft.com, and entered this resources there on the FarStar / Tatooine page WITH stats.
Isiawaiide, Hardened Arveshium Steel (Entered By MillaMerani / Not Verified)
CR=660, CD=307, DR=857, HR=903, MA=579, OQ=446, SR=35, UT=522 * (Edit Stats)
» Marked as available 3 days ago by SWGCraft.co.uk (Unavailable)
Am I mistaken that the import script of this site is supposed to update entries made here without stats if the old site contains the same resources with stat values?

I made the full-stat entry on swgcraft.com yesterday, and by now this site should have been updated to show the full-stat entry.

EDIT:


I will do a full update on THIS site today, let's see what the export script will do to the old site.

2nd EDIT:

Now changes made to this site do not seem to appear on the old site... have you turned off the export script again?
Last edited by Milla on Wed Oct 17, 2007 10:42 am, edited 1 time in total.

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Post by Zimoon » Wed Oct 17, 2007 7:36 am

May I ask a silly question to the devs:

Do the SWGCraft.co.uk "galaxy" synchronise with the SWGCraft.com "galaxy"?

If so I may run a series of test cases and see what happens, right?
/Z

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Post by Sobuno » Wed Oct 17, 2007 8:11 am

Zimoon wrote:May I ask a silly question to the devs:

Do the SWGCraft.co.uk "galaxy" synchronise with the SWGCraft.com "galaxy"?

If so I may run a series of test cases and see what happens, right?
/Z
Well, only the mailparser synchronization is on atm and SWGCraft.com isn't exported on their site (As in, it is not in the XML/CSV file that they make)

But yeah, SWGCraft.co.uk server and SWGCraft.com server should be linked

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Post by Zimoon » Wed Oct 17, 2007 8:17 am

Sobuno wrote:It's hard testing though as the SWGCraft.com server over there isn't exported
Found a reply to my own question :oops:
/Z

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Post by Sobuno » Wed Oct 17, 2007 9:46 am

Milla wrote:Now I noticed something:

On Farstar / Tatooine there is an entry made by Isskozz:
Isiawaiide, Hardened Arveshium Steel (Entered By Isskozz / Not Verified) (Unavailable)
No stats available for this resource (Edit Stats)
Yesterday, I updated swgcraft.com, and entered this resources there on the FarStar / Tatooine page WITH stats.
Isiawaiide, Hardened Arveshium Steel (Entered By MillaMerani / Not Verified)
CR=660, CD=307, DR=857, HR=903, MA=579, OQ=446, SR=35, UT=522 * (Edit Stats)
» Marked as available 3 days ago by SWGCraft.co.uk (Unavailable)
Am I mistaken that the import script of this site is supposed to update entries made here without stats if the old site contains the same resources with stat values?

I made the full-stat entry on swgcraft.com yesterday, and by now this site should have been updated to show the full-stat entry.

EDIT:


I will do a full update on THIS site today, let's see what the export script will do to the old site.

You are correct, should be fixed now (Was something to do with us changing storing of empty stats from a NULL value to a 0 value)

Tekro
Apprentice Crafter
Posts: 60
Joined: Tue Sep 25, 2007 2:08 pm

Post by Tekro » Wed Oct 17, 2007 4:37 pm

I just wanted to add that I've been actively updating all of the Bloodfin inorganics for the last two months on swgcraft and haven't noticed any destruction/deletion of any entries.

I'm not discounting what Milla stated, just letting you know in case any comparisons can be made between the two server resources to find the problem.
Wepo Gage

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Post by Zimoon » Wed Oct 17, 2007 6:32 pm

Tekro wrote:I just wanted to add that I've been actively updating all of the Bloodfin inorganics for the last two months on swgcraft and haven't noticed any destruction/deletion of any entries.

I'm not discounting what Milla stated, just letting you know in case any comparisons can be made between the two server resources to find the problem.
The problem seems to involve that a player acts both here and at the old and rusty SWGCraft.com. While I am into the theoretical details (there are a bunch of scenarios, I promise ;) ) would you mind adding a few at both sides? Do not do more than a few each kind of test you can come up with. That could be, one day add them at SWGCraft without stats and an hour later add the stats here, note down the result. Another day, vice versa. Third day, without stats at SWGCraft and directly afterwards with stats here. Fourth day, vice versa.

I believe marking unavailable is disabled so you cannot perform any tests on that for now.

When we, together, can rule out a few scenarios there are less options prone to errors and finally we will spot what this eluding bug is.

/Z

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Post by Sobuno » Wed Oct 17, 2007 7:36 pm

Zimoon wrote:
Tekro wrote:I just wanted to add that I've been actively updating all of the Bloodfin inorganics for the last two months on swgcraft and haven't noticed any destruction/deletion of any entries.

I'm not discounting what Milla stated, just letting you know in case any comparisons can be made between the two server resources to find the problem.
The problem seems to involve that a player acts both here and at the old and rusty SWGCraft.com. While I am into the theoretical details (there are a bunch of scenarios, I promise ;) ) would you mind adding a few at both sides? Do not do more than a few each kind of test you can come up with. That could be, one day add them at SWGCraft without stats and an hour later add the stats here, note down the result. Another day, vice versa. Third day, without stats at SWGCraft and directly afterwards with stats here. Fourth day, vice versa.

I believe marking unavailable is disabled so you cannot perform any tests on that for now.

When we, together, can rule out a few scenarios there are less options prone to errors and finally we will spot what this eluding bug is.

/Z
Only mail parser is sending new resources to SWGCraft.com atm

I can reenable site synch if you want me to?

User avatar
Zimoon
Forum Moderator
Posts: 4817
Joined: Mon May 14, 2007 6:55 am
Location: Stockholm, SE
Contact:

Post by Zimoon » Wed Oct 17, 2007 8:40 pm

Is it possible to on only enable it partly and leave the unavailable thing out at the moment??
/Z

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Post by Sobuno » Wed Oct 17, 2007 8:41 pm

Zimoon wrote:Is it possible to on only enable it partly and leave the unavailable thing out at the moment??
/Z
As in enabling the Add Resources page to sync? Yeah, will be possible for a few days still (I'm in the process of reworking some of the code to make sure bug fixes are applied to every page that adds resources)

Post Reply

Who is online

Users browsing this forum: No registered users and 24 guests