Help with SWGaide & Basilisk needed

Moderator: Forum Moderator

User avatar
HydroTek
Intermediate Crafter
Posts: 138
Joined: Sat Jun 16, 2007 1:43 am
Location: Indiana USA

Re: Help with SWGaide & Basilisk needed

Post by HydroTek » Mon Jul 16, 2012 6:09 am

I'm running Win7 64Pro ...look for C:\Program Files (x86)\Java\jre7\bin and be sure javaw.exe is set to run in admin mode. Also make a shortcut to SwgAide.jar on your desktop(or where ever you want) set the properties to run in admin mode as well.

I made a few other alterations as well ...
  • 1. Make a new folder C:\Program Files (x86)\StarWarsGalaxies (if that folder already exists, rename it with Old on the end of the name)
  • 2. move the folder SwgEmu into there
  • 3. be sure to update the paths in the SwgEmu launcher to the new location
  • 4. Find Notepad.exe in your Windows folder and copy it to StarWarsGalaxies/SwgEmu folder you created ..now rename notepad to SwgClient_r.exe
  • 5. if SwgAide isnt already in C:\Program Files\SwgAide ...move or copy the swgaide.jar file there (be sure your desktop shortcut points to this file
The reason for all this is ..SwgAide install routine looks for the SwgClient_r.exe file by default, it expects to find it in the StarWarsGalaxies folder ...still with me? ,,good. The renamed Notepad file will "fool" the install routine (it serves no other purpose, and is safe to leave there), if you cant see the .exe file names, you will need to enable that in windows folder properties.

There will still be errors in SwgAide concerning schematics, but the resources part will work correctly. Java is not my strong point, but I am looking thru the code to see if it can work with the Basilisk information. Input from someone that "knows" java well would be welcomed :)
If it's stuck :x ...force it ...if it breaks, :shock: you needed a new one anyway :)
Characters(Legends): HydroTek, Ditty, and Talo ..give a shout if you see me in game

Zarrak Galactic
Novice Crafter
Posts: 28
Joined: Sat Aug 02, 2008 4:23 pm
Location: Vancouver, BC Canada
Contact:

Re: Help with SWGaide & Basilisk needed

Post by Zarrak Galactic » Fri Jul 27, 2012 4:41 pm

HydroTek wrote:I'm running Win7 64Pro ...look for C:\Program Files (x86)\Java\jre7\bin and be sure javaw.exe is set to run in admin mode. Also make a shortcut to SwgAide.jar on your desktop(or where ever you want) set the properties to run in admin mode as well.

I made a few other alterations as well ...
  • 1. Make a new folder C:\Program Files (x86)\StarWarsGalaxies (if that folder already exists, rename it with Old on the end of the name)
  • 2. move the folder SwgEmu into there
  • 3. be sure to update the paths in the SwgEmu launcher to the new location
  • 4. Find Notepad.exe in your Windows folder and copy it to StarWarsGalaxies/SwgEmu folder you created ..now rename notepad to SwgClient_r.exe
  • 5. if SwgAide isnt already in C:\Program Files\SwgAide ...move or copy the swgaide.jar file there (be sure your desktop shortcut points to this file
The reason for all this is ..SwgAide install routine looks for the SwgClient_r.exe file by default, it expects to find it in the StarWarsGalaxies folder ...still with me? ,,good. The renamed Notepad file will "fool" the install routine (it serves no other purpose, and is safe to leave there), if you cant see the .exe file names, you will need to enable that in windows folder properties.

There will still be errors in SwgAide concerning schematics, but the resources part will work correctly. Java is not my strong point, but I am looking thru the code to see if it can work with the Basilisk information. Input from someone that "knows" java well would be welcomed :)
Ok, tried to follow these instructions but there is no option to run SWGAide as admin. There was something about block and I made sure that was cleared. At this point, SWGAide thinks it's downloading new items because it says there are 51 resources downloaded but the newest is 11 days old now, tho it's always the same one. I have no filter to only show certain number of days and removed guards to see if that was it but no luck. It also doesn't see my saved mail.

At this point SWGAide doesn't seem to be working at all. I was also unable to list the harvs I had placed because the correct resource wasn't there. I tried just a random resource and that was ok but it does defeat the purpose. This is version 0.9.8-Sobuno. Is that the correct one? Please let me know what I can do to get this working again. I feel so lost without it!

Wieli
Novice Crafter
Posts: 23
Joined: Fri Apr 01, 2011 7:03 am

Re: Help with SWGaide & Basilisk needed

Post by Wieli » Mon Jul 30, 2012 8:32 am

I just so want to help with get this project up and running, i have downloaded and checked on the sourcecode but it just way too advanced for me and my javaskills (none)

If anyone decides to pick up on this let me know. I could do data entry or whatever to help with get SWGAide up and running properly.

Anyone that have a modified and better working version? That dont give 2 million level and schematic errors etc :)

Zarrak Galactic
Novice Crafter
Posts: 28
Joined: Sat Aug 02, 2008 4:23 pm
Location: Vancouver, BC Canada
Contact:

Re: Help with SWGaide & Basilisk needed

Post by Zarrak Galactic » Mon Jul 30, 2012 7:39 pm

Wieli wrote:I just so want to help with get this project up and running, i have downloaded and checked on the sourcecode but it just way too advanced for me and my javaskills (none)

If anyone decides to pick up on this let me know. I could do data entry or whatever to help with get SWGAide up and running properly.

Anyone that have a modified and better working version? That dont give 2 million level and schematic errors etc :)
Don't know if this will work for you. I deleted everything and downloaded SWGAIDE-Sobuno again, installing it to a fresh directory and most of it is working. I can get the new resources and mails are saved. It won't generate the sales list or list of customers and such as it used to do. The harvesting panel works to some extent but I wouldn't trust it completely.

I would also be more than happy to help in whatever way I can if someone wants to try to get this going again.

Wieli
Novice Crafter
Posts: 23
Joined: Fri Apr 01, 2011 7:03 am

Re: Help with SWGaide & Basilisk needed

Post by Wieli » Mon Jul 30, 2012 11:03 pm

Zarrak Galactic wrote:
Wieli wrote:I just so want to help with get this project up and running, i have downloaded and checked on the sourcecode but it just way too advanced for me and my javaskills (none)

If anyone decides to pick up on this let me know. I could do data entry or whatever to help with get SWGAide up and running properly.

Anyone that have a modified and better working version? That dont give 2 million level and schematic errors etc :)
Don't know if this will work for you. I deleted everything and downloaded SWGAIDE-Sobuno again, installing it to a fresh directory and most of it is working. I can get the new resources and mails are saved. It won't generate the sales list or list of customers and such as it used to do. The harvesting panel works to some extent but I wouldn't trust it completely.

I would also be more than happy to help in whatever way I can if someone wants to try to get this going again.
I dont have that much problem with the resources and that anymore.

The biggest problem for me is that all of a sudden the "Schematic tab" stops working. When iclick it its just empty, It has something to do with the DAt file but i dont know what. Since as soon as i delete the DAT file the Schematic tab works again.

User avatar
HydroTek
Intermediate Crafter
Posts: 138
Joined: Sat Jun 16, 2007 1:43 am
Location: Indiana USA

Re: Help with SWGaide & Basilisk needed

Post by HydroTek » Tue Jul 31, 2012 2:10 pm

Zarrak wrote:Ok, tried to follow these instructions but there is no option to run SWGAide as admin.
You are correct, there is not an option to run SwgAide in Admin, ..I was in a hurry and didn't check :oops:

The other parts of my instructions do work tho 8) for the installation.

...I found a few days later that the resources were not updating correctly, it seems there are too many errors for SwgAide to handle, so it gives random results (read your error log files) (delete the log files and re-run SwgAide for fresh logs). You can delete the .dat file and run SwgAide again to rebuild it, but the results may be less than desirable.

Is any here running SwgAide on Win XP? ...I have not yet found time to assemble an XP box to test on, currently running Win 7, and it seems to have "issues" blocking processes and not informing me ..so it is hard to figure if there is a Win7 "problem" or SwgAide.

Data entry into SwgAide is made from this site automajically, ..it worked well before, so I think there is just a small change that needs to be made to get it working again. The code is well documented, but also large and without prior knowledge of the inner workings, it will take some time to sift thru. I'm glad to see others looking as well, ..more eyes on this, we may find the problem sooner.

SwgAide is a handy tool that compliments SwgCraft so well ..they are like the right and left hand of crafting :)
If it's stuck :x ...force it ...if it breaks, :shock: you needed a new one anyway :)
Characters(Legends): HydroTek, Ditty, and Talo ..give a shout if you see me in game

Zarrak Galactic
Novice Crafter
Posts: 28
Joined: Sat Aug 02, 2008 4:23 pm
Location: Vancouver, BC Canada
Contact:

Re: Help with SWGaide & Basilisk needed

Post by Zarrak Galactic » Tue Jul 31, 2012 10:16 pm

HydroTek wrote:
Zarrak wrote:Ok, tried to follow these instructions but there is no option to run SWGAide as admin.
You are correct, there is not an option to run SwgAide in Admin, ..I was in a hurry and didn't check :oops:

The other parts of my instructions do work tho 8) for the installation.

...I found a few days later that the resources were not updating correctly, it seems there are too many errors for SwgAide to handle, so it gives random results (read your error log files) (delete the log files and re-run SwgAide for fresh logs). You can delete the .dat file and run SwgAide again to rebuild it, but the results may be less than desirable.

Is any here running SwgAide on Win XP? ...I have not yet found time to assemble an XP box to test on, currently running Win 7, and it seems to have "issues" blocking processes and not informing me ..so it is hard to figure if there is a Win7 "problem" or SwgAide.

Data entry into SwgAide is made from this site automajically, ..it worked well before, so I think there is just a small change that needs to be made to get it working again. The code is well documented, but also large and without prior knowledge of the inner workings, it will take some time to sift thru. I'm glad to see others looking as well, ..more eyes on this, we may find the problem sooner.

SwgAide is a handy tool that compliments SwgCraft so well ..they are like the right and left hand of crafting :)
I've just put SWGAide on my XP comp and, so far it can't find my characters even though I know the directory is correct. I'll keep working with it after they reboot the server.

Wieli
Novice Crafter
Posts: 23
Joined: Fri Apr 01, 2011 7:03 am

Re: Help with SWGaide & Basilisk needed

Post by Wieli » Tue Jul 31, 2012 10:52 pm

HydroTek wrote:
Zarrak wrote:Ok, tried to follow these instructions but there is no option to run SWGAide as admin.
You are correct, there is not an option to run SwgAide in Admin, ..I was in a hurry and didn't check :oops:

The other parts of my instructions do work tho 8) for the installation.

...I found a few days later that the resources were not updating correctly, it seems there are too many errors for SwgAide to handle, so it gives random results (read your error log files) (delete the log files and re-run SwgAide for fresh logs). You can delete the .dat file and run SwgAide again to rebuild it, but the results may be less than desirable.

Is any here running SwgAide on Win XP? ...I have not yet found time to assemble an XP box to test on, currently running Win 7, and it seems to have "issues" blocking processes and not informing me ..so it is hard to figure if there is a Win7 "problem" or SwgAide.

Data entry into SwgAide is made from this site automajically, ..it worked well before, so I think there is just a small change that needs to be made to get it working again. The code is well documented, but also large and without prior knowledge of the inner workings, it will take some time to sift thru. I'm glad to see others looking as well, ..more eyes on this, we may find the problem sooner.

SwgAide is a handy tool that compliments SwgCraft so well ..they are like the right and left hand of crafting :)
I'm really trying to figure this thing out and trying to minimize the the error were seeing. I'm just completely nullified with Java so i have no idea what i'm doing. Would be nice to find someone that could take SWGAide under their wings.

Zarrak Galactic
Novice Crafter
Posts: 28
Joined: Sat Aug 02, 2008 4:23 pm
Location: Vancouver, BC Canada
Contact:

Re: Help with SWGaide & Basilisk needed

Post by Zarrak Galactic » Wed Aug 01, 2012 2:18 pm

I've gone ahead and made the changes as suggested in the post and put swgemu inside a sart wars galaxies folder, etc. and now it seems the resources are more current. One thing I can't get to work tho is the mail. It will show the mail under auctions but all the tabs where I would normally be shown the customers, sales, etc. all of that section is blank. Do I need to do something more to get that to work?

User avatar
HydroTek
Intermediate Crafter
Posts: 138
Joined: Sat Jun 16, 2007 1:43 am
Location: Indiana USA

Re: Help with SWGaide & Basilisk needed

Post by HydroTek » Wed Aug 01, 2012 2:26 pm

:arrow: First of all ..please do not quote the whole previous post ..it only leads to a Wall Of Text ..then Too Long Didnt Read.

Second, the instructions I posted Do work, I have tested them several times ..you dont have to follow them if you don't want to, but you will still have to point SwgAide to your installation of the Emu for it to find your toons. Usually it takes a couple of restarts for SwgAide to list your toons ..if that isnt your experience ..just delete everything in the SwgAide directory except the SwgAide.jar file and start again.

Third, be sure you have checked show all hidden files, and unchecked hide extensions for known file types in folder options.

Delete the Log files in SwgAide, before you run it ..then read them after you run SwgAide one time, to see "fresh" errors ..you will see at the top an error for SWGProfManager:populateProfLevels, this I believe is causing the schematic errors
..also there is this error C:\Program Files (x86)\StarWarsGalaxies\testcenter SWG DIR:C:\Program Files (x86)\StarWarsGalaxies\testcenter No server file found.(I have not found where "testcenter" part of the path is coming from)
.. and another example EXCEPTION == SWGSchematic:getSkillLevels: SWGSchematic[Gas Pocket Survey Device (5557)]: Invalid level: 100 java.lang.IllegalArgumentException: Invalid level: 100

I was able to get an XP box together last night and get Eclipse installed on it along with Swgaide source files ..there are still several errors in the resource imports ..but less then on the Win7 box. I will hookup i-net access to it tonight, so I can see if SwgAide gathers resource information. Gotta run some cables, as the XP box(old tech, so no wireless capabilities) is downstairs in my workshop.
If it's stuck :x ...force it ...if it breaks, :shock: you needed a new one anyway :)
Characters(Legends): HydroTek, Ditty, and Talo ..give a shout if you see me in game

User avatar
HydroTek
Intermediate Crafter
Posts: 138
Joined: Sat Jun 16, 2007 1:43 am
Location: Indiana USA

Re: Help with SWGaide & Basilisk needed

Post by HydroTek » Wed Aug 01, 2012 2:29 pm

Zarrak Galactic wrote:I've gone ahead and made the changes as suggested in the post and put swgemu inside a sart wars galaxies folder, etc. and now it seems the resources are more current. One thing I can't get to work tho is the mail. It will show the mail under auctions but all the tabs where I would normally be shown the customers, sales, etc. all of that section is blank. Do I need to do something more to get that to work?
You used to have todo a /mailsave from the game before that would work, I have not tried that part yet, as I do not keep any important information with SwgAide yet ..still experimenting to get the resources working correctly first.
If it's stuck :x ...force it ...if it breaks, :shock: you needed a new one anyway :)
Characters(Legends): HydroTek, Ditty, and Talo ..give a shout if you see me in game

Zarrak Galactic
Novice Crafter
Posts: 28
Joined: Sat Aug 02, 2008 4:23 pm
Location: Vancouver, BC Canada
Contact:

Re: Help with SWGaide & Basilisk needed

Post by Zarrak Galactic » Wed Aug 01, 2012 6:02 pm

I won't quote any posts, lest you get more upset. I only meant to state that this is where I'm at and what I'm trying to do. I've followed all your suggestions and now finally think I've got it going. Thank you for that, I do appreciate it.

The mail issue is one I will figure out on my own. I have done the /mailsave and the mails are there, just the other tabs have not been populated as they used to be. I will go learn Java and see if I can figure this out.

Oh and the reference to XP was just in response to your query, as I have an XP box and thought I could help.

Thanks for your help.

Wieli
Novice Crafter
Posts: 23
Joined: Fri Apr 01, 2011 7:03 am

Re: Help with SWGaide & Basilisk needed

Post by Wieli » Wed Aug 01, 2012 10:47 pm

I have been able to fix some errors. Though since i started from the beginnins with Zimons sourcecode im not able to get a log file. Which makes testing alot harder.

Anyone else got this from using the raw source code?

The ERROR log never appear at all and the regular Log is always empty.


Im not sure if i have done it in some other way then Sobuno, but now i never fail to find the different servers when i start up a new .DAT file.
Last edited by Wieli on Wed Aug 01, 2012 10:54 pm, edited 1 time in total.

Wieli
Novice Crafter
Posts: 23
Joined: Fri Apr 01, 2011 7:03 am

Re: Help with SWGaide & Basilisk needed

Post by Wieli » Wed Aug 01, 2012 10:52 pm

Or does Sobuno have his source code somewhere to download?

i know that the log work in that version.

User avatar
HydroTek
Intermediate Crafter
Posts: 138
Joined: Sat Jun 16, 2007 1:43 am
Location: Indiana USA

Re: Help with SWGaide & Basilisk needed

Post by HydroTek » Thu Aug 02, 2012 1:05 am

@Zarrak ..the written word often does not convey this authors thoughts/feelings well ..it was not my intention to come across as gruff ...I do appreciate any help or suggestions on this project. <Hydro reminds self to be more thoughtful>
If it's stuck :x ...force it ...if it breaks, :shock: you needed a new one anyway :)
Characters(Legends): HydroTek, Ditty, and Talo ..give a shout if you see me in game

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests