Page 1 of 1

nge mode

Posted: Mon Aug 20, 2018 10:32 pm
by solarisjedi
Could it please be considered that NGE mode cookie set to a much longer expiry? It seems to expire very fast.

Also could it be considered that a &mode=nge be used for any URL on the site? E.g. if I want to share a link to an NGE schematic and the person I shared with has never visited site, the NGE schematic link throws a not found. If the link could includ a mode=nge (for anything on the site really) it would certainly help clear up lots of confusion when trying to share links to NGE based things on the site.

Thanks

Re: nge mode

Posted: Wed Aug 22, 2018 6:31 pm
by Sobuno
We do not set a cookie as such, but just use the session variables to hold what mode you are in - So they last exactly as long as your session :)

Regarding the second thing, appending &nge should work - I just fixed a bug where it would only take effect on the second refresh though.

Re: nge mode

Posted: Thu Aug 23, 2018 2:02 am
by solarisjedi
Thanks, maybe the session was dropping on the server because I am always logged in and it nge mode would fall off after a few minutes.

However regarding appending the &nge, I just tested and it is working good now, thank you!

Would it be possible to maybe have a permalink type share link on schematics pages that include server id and whether nge mode or not eg: http://swgcraft.org/dev/viewschematic.p ... er=138&nge

I had to manually add the server and nge to the url in order to properly share it, if this was in the markup itself might make it easier for folks who aren't tech savvy to share it? Just thoughts.

Thanks again!